Lompat ke konten Lompat ke sidebar Lompat ke footer

Cisco | BGP - Advanced Routing

 
Berikut konfigurasinya dimasing-masing router
Konfigurasi Router R1
hostname R1
clock timezone  WIB 7
int gi0/0
 ip add 10.1.2.1 255.255.255.252
 no shut

int gi0/1
 ip add 10.1.1.1 255.255.255.252
 no shut

int lo0
 ip add 172.16.1.1 255.255.255.255
 no shut

router ospf 1
 router-id 172.16.1.1
 passive-interface gi0/1
 network 10.1.1.0 0.0.0.3 area 0
 network 10.1.2.0 0.0.0.3 area 0
 network 172.16.1.1 0.0.0.0 area 0
 exit

router bgp 65012
 neighbor 172.16.2.2 remote-as 65012
 neighbor 172.16.2.2 update-source lo0
 end
---
Konfigurasi Router  R2
hostname R2
clock timezone  WIB 7
int lo0
 ip add 172.16.2.2 255.255.255.255
 no shut

int gi0/0
 ip add 10.1.2.2 255.255.255.252
 no shut

int gi0/1
 ip add 10.2.3.1 255.255.255.252
 no shut

 int gi0/2
 ip add 10.2.4.1 255.255.255.252
 no shut

router ospf 2
 router-id 172.16.2.2
 network 10.1.2.0 0.0.0.3 area 0
 network 172.16.2.2 0.0.0.0 area 0
 exit

router bgp 65012
 neighbor 172.16.1.1 remote-as 65012
 neighbor 172.16.1.1 update-source lo0
 neighbor 10.2.3.2 remote-as 65003
 neighbor 10.2.4.2 remote-as 65004
 exit

TAMBAHKAN PERINTAH INI di R2 SUPAYA NETWORK (OSPF) ANTARA R1 DAN R2 DIKENALI DI ROUTER LAIN
router bgp 65012
 redistribute ospf 2
  
DAN TAMBAHAN KONFIGURASI: NEXT-HOP-SELF DI R2, SUPAYA R1 MENGENALI NETWORK YG ADA DI R3 DAN R4.
router bgp 65012
neighbor 172.16.1.1 next-hop-self
end

clear ip bgp 172.16.1.1 out
------
Konfigurasi Router R3
hostname R3
clock timezone  WIB 7
int lo0
 ip add 172.16.3.3 255.255.255.255
 no shut

int gi0/1
 ip add 10.3.5.1 255.255.255.252
 no shut

int gi0/0
 ip add 10.2.3.2 255.255.255.252
 no shut

 int gi0/2
 ip add 10.3.4.1 255.255.255.252
 no shut

 int gi0/3
 ip add 172.16.31.1 255.255.255.192
 ip add 172.16.31.65 255.255.255.192 secondary
 ip add 172.16.31.129 255.255.255.192 secondary
 ip add 172.16.31.193 255.255.255.192 secondary
 no shut
 descrip "External Network"
 no shut

DI R3 DAN R4 TIDAK PERLU IGP, KARENA ROUTERNYA HANYA SENDIRI DIAREA TERSEBUT, JADI CUKUP BGP SAJA.
router bgp 65003
 neighbor 10.2.3.1 remote-as 65012
 neighbor 10.3.4.2 remote-as 65004
 neighbor 10.3.5.2 remote-as 65056
 exit

ADVERTISE NETOWKR CONNECTED KE BGP
router bgp 65003
network 10.2.3.0 mask 255.255.255.248
network 10.3.3.0 mask 255.255.255.248
network 10.3.5.0 mask 255.255.255.248
network 172.16.3.3 mask 255.255.255.248
 end
-----
Konfigurasi Router R4
hostname R4
clock timezone  WIB 7

int lo0
 ip add 172.16.4.4 255.255.255.255
 no shut

int gi0/1
 ip add 10.4.5.1 255.255.255.252
 no shut

int gi0/0
 ip add 10.2.4.2 255.255.255.252
 no shut

 int gi0/2
 ip add 10.3.4.2 255.255.255.252
 no shut

router bgp 65004
 neighbor 10.2.4.1 remote-as 65012
 neighbor 10.3.4.1 remote-as 65003
 neighbor 10.4.5.2 remote-as 65056
 exit
---
ADVERTISE NETWORK CONNECTED di BGP
router bgp 65004
network 10.2.4.0 mask 255.255.255.248
network 10.3.4.0 mask 255.255.255.248
network 10.4.5.0 mask 255.255.255.248
network 172.16.4.4 mask 255.255.255.248
end

Konfigurasi Router R5
hostname R5
clock timezone  WIB 7

int lo0
 ip add 172.16.5.5 255.255.255.255
 no shut

int gi0/0
 ip add 10.4.5.2 255.255.255.252
 no shut

int gi0/1
 ip add 10.3.5.2 255.255.255.252
 no shut

 int gi0/2
 ip add 10.5.6.1 255.255.255.252
 no shut

int loo1
 ip add 172.6.5.5 255.255.255.255
 no shu

router eigrp R5
 address-family ipv4 unicast autonomous-system 65056
 eigrp router-id 172.16.5.5
 network 10.5.6.0 0.0.0.3
 network 172.16.5.5 0.0.0.0
 exit

router bgp 65056
 neighbor 10.3.5.1 remote-as 65003
 neighbor 10.4.5.1 remote-as 65004
 redistribute eigrp 65056
 exit

ASK: Gimana caranya supaya R6 ini dapat menuju semua router, karena R6 ini hanya tau AS65056..? karna R6 tdk pakai BGP. Maka caranya: R5 hrs meng-advertise BGP ke ke R6 menggunakan EIGRP menggunakan redistribute.Berikut perintahnya: 

router eigrp R5
 address-family ipv4 unicast autonomous-system 65056
 topology base
 redistribute bgp 65056 metric 1000000 10 1 1 1
 
exit

Noted: 1000000 10 1 1 1 (BW, DELAY, RELIABILITY, LOAD, MTU)
---
Konfigurasi Router R6
hostname R6
clock timezone  WIB 7
int gi0/1
 ip add 10.6.6.1 255.255.255.252
 no shut

int gi0/0
 ip add 10.5.6.2 255.255.255.252
 no shut

int lo0
 ip add 172.16.6.6 255.255.255.255
 no shu

router eigrp R6
 address-family ipv4 unicast autonomous-system 65056
 eigrp router-id 172.16.6.6
 network 10.5.6.0 0.0.0.3
 network 10.6.6.0 0.0.0.3
 network 172.16.6.6 0.0.0.0
 af-interface gi0/1
 passive-interface
 exit
===============================
VERIFIKASI
sh ip bgp neighbors
sh ip bgp summary
sh ip bgp
sh ip bgp rib-failure

JIKA INGIN INTERNET DAPAT DITERUSKAN DARI R4 KE ROUTER LAIN, MAKA TAMBAHKAN PERINTAH BERIKUT INI DI R4.

ip nat inside source list 1 interface GigabitEthernet0/3 overload
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
access-list 1 permit any

interface GigabitEthernet0/2
 ip nat inside
!
interface GigabitEthernet0/3
 ip nat outside
!
router bgp 65004
 redistribute static
 default-information originate

r-R-Failure = tdk akn diinstal dirouter BGP asalanya, karena nilai AD yg lebh tinggi

VERIFIKASI di R5:
sh ip bg rib-failure
sh ip roue | inc 10.4.5.0


 

 

Posting Komentar untuk "Cisco | BGP - Advanced Routing"