Lompat ke konten Lompat ke sidebar Lompat ke footer

Cisco | MPLS - L2VPN - Ecapsulation - Tagged Frame (Vlan10, 20)

Step 1: Konfigure IP address 

Router-P1
host P1
int lo0
ip add 1.1.1.1 255.255.255.255
exi

int gi0/0
no shu
 ip add 11.11.11.1 255.255.255.0
 exi

int gi0/1
 no shu
 ip add 12.12.12.1 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 14.14.14.1 255.255.255.0
 exi

Router-P2
host P2
int lo0
ip add 2.2.2.2 255.255.255.255
exi

int gi0/0
 no shu
 ip add 12.12.12.2 255.255.255.0
 exi

int gi0/1
 no shu
 ip add 13.13.13.2 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 15.15.15.1 255.255.255.0
 exi

Router-P3
Router P3
host P3
int lo0
ip add 3.3.3.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 11.11.11.3 255.255.255.0
 exi

int gi0/1
 no shu
 ip add 13.13.13.3 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 16.16.16.1 255.255.255.0
 exi

Router-PE1
host PE1
int lo0
ip add 10.0.0.1 255.255.255.255
exi

int gi0/0
 no shu
 ip add 14.14.14.2 255.255.255.0
 exi

Router-PE2
host PE2
int lo0
ip add 10.0.0.2 255.255.255.255
exi

int gi0/0
 no shu
 ip add 15.15.15.2 255.255.255.0
 exi

Router-PE3
host PE3
int lo0
ip add 10.0.0.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 16.16.16.2 255.255.255.0
 exi

Step 2 : (Advertise network routing OSPF)


Router P1
router ospf 1
net 11.11.11.1 0.0.0.0 are 0
net 14.14.14.1 0.0.0.0 are 0
net 12.12.12.1 0.0.0.0 are 0
net 1.1.1.1 0.0.0.0 are 0
exi

Router P2
router ospf 1
net 12.12.12.2 0.0.0.0 are 0
net 13.13.13.2 0.0.0.0 are 0
net 15.15.15.1 0.0.0.0 are 0
net 2.2.2.2 0.0.0.0 are 0
exi

Router P3
router ospf 1
net 13.13.13.3 0.0.0.0 are 0
net 16.16.16.1 0.0.0.0 are 0
net 11.11.11.3 0.0.0.0 are 0
net 3.3.3.3 0.0.0.0 are 0
exi

Router PE1
router ospf 1
net 14.14.14.2 0.0.0.0 are 0
net 10.0.0.1 0.0.0.0 are 0
exi

Router PE2
router ospf 1
net 15.15.15.2 0.0.0.0 are 0
net 10.0.0.2 0.0.0.0 are 0
exi

Router PE3
router ospf 1
net 16.16.16.2 0.0.0.0 are 0
net 10.0.0.3 0.0.0.0 are 0
exi

Step 3 : (Konfig MPLS di  router pada ISP area yaitu: (P1,P2,P3, PE1, PE2 dan PE3)

Router P1

mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exi

Router P2
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exi

Router P3
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exit

Router PE1

mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Router PE2

mpls label protocol ldp
mpls ldp router-id lo0 force

int ra gi0/0-2
mpls ip
exi

Router PE3

mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Verifkasi:
#sh mpls ldp neighbor
#sh mpls forwarding-table

Step 4: Konfigurasi xconnect antar router PE dengan men-tagged VLAN 10, VLAN 20 pd router PE1, PE2 dan PE3

Router PE1
pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.10
 encapsulation dot1q 10
 desc 'LINK TO BCA-2"
 no shu
 xconnect 10.0.0.3 45 encapsulation mpls pw-class PW-CE-BCA
  exi
  exit

pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
 encapsulation dot1q 20
 no shu
 desc 'LINK TO BRI-2"
 xconnect 10.0.0.3 100 encapsulation mpls pw-class PW-CE-BRI
 exit

Router PE2
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
desc 'LINK TO BRI-1"
encapsulation dot1q 20
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 exit

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.10
encapsulation dot1q 10
 no shu
 desc 'LINK TO BCA-1"
 xconnect 10.0.0.1 45 encapsulation mpls pw-class PW-CE-BRCA
 ex

Router PE3
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
encapsulation dot1q 20
desc 'LINK TO BRI-1"
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 exi
exit

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.10
encapsulation dot1q 10
 no shu
 desc 'LINK TO BCA-1"
 xconnect 10.0.0.1 45 encapsulation mpls pw-class PW-CE-BCA
 ex
 exit

VERIFIKASI:
PE1
#do sh run | sec pse
#ping mpls pseudowire 10.0.0.3 100
#ping mpls pseudowire 10.0.0.3 45

Step 5: Konfigurasikan IP interface VLAN router BCA-1, BCA-2, dan switch SW-BRI-1,SW BRI-2)

Router BCA-1
host BCA-1
interface gi0/0.10
 encapsulation dot1q 10
 ip address 10.28.10.1 255.255.255.0
 no shu
 exi

Router BCA-2
host BCA-2
interface gi0/0.10
encapsulation dot1q 10
 ip address 10.28.10.2 255.255.255.0
 no shu
 exi

VERIFKASI





















Step-6 Konfig Switch  SW-BRI-1 dan SW-BRI-2
SWITCH SW-BRI-1
host SW-BRI-1
vlan 10
vlan 20
int gi0/0
switch trunk encap do1q
switch mode trunk
exit

int gi0/1
switch mode acc
switch access vlan 10
exit

int gi0/2
switch mode acc
switch access vlan 20
exit


SWITCH SW-BRI-2

host SW-BRI-2   
vlan 10
vlan 20
int gi0/0
switch trunk encap do1q
switch mode trunk
exit


int gi0/1
switch mode acc
switch access vlan 10
exit

int gi0/2
switch mode acc
switch access vlan 20
exit

Lalu set ip di komputer BRI-1 DAN BRI-2
Verifikasi:




 







Sukess..!! Done


Posting Komentar untuk "Cisco | MPLS - L2VPN - Ecapsulation - Tagged Frame (Vlan10, 20)"