Cisco | BGP - Synchronization
Untuk sekarang secara default synchronization sudah di disable. Pada gambar diatas kita bisa melihat terdapat 5 router dan 3 AS yang berbeda. Ketika kita menghubungkan router R5 dan R3 akan melewati AS 10 sebagai AS transit. iBGP dikonfigurasi antara R1 dan R2 sedangkan router R4 tidak menjalankan BGP melainkan routing OSPF. Maka dari itu supaya R1 dan R2 dapat membentuk sesi peer internal BGP, dan dapat berkomuniasi dengan mendistribusikan prefix masing IP loop nya, maka dibutuhkan beberapa step konfigurasi.
!hostname R1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
ip address 172.16.11.1 255.255.255.0
!
interface Ethernet0/0
ip address 12.12.12.1 255.255.255.252
ip ospf network point-to-point
no shut
!
interface Ethernet0/2
ip address 14.14.14.1 255.255.255.252
no shut
!
router ospf 1
network 12.12.12.0 0.0.0.3 area 0
!
router bgp 10
bgp router-id 172.16.1.1
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.0
network 172.16.11.0 mask 255.255.255.0
neighbor 14.14.14.2 remote-as 40
neighbor 15.15.15.1 remote-as 10
!
hostname R2
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface Loopback1
ip address 172.16.22.1 255.255.255.0
!
interface Ethernet0/0
ip address 15.15.15.1 255.255.255.252
ip ospf network point-to-point
duplex auto
!
interface Ethernet0/1
ip address 13.13.13.2 255.255.255.252
duplex auto
!
router ospf 1
network 15.15.15.0 0.0.0.3 area 0
!
router bgp 10
bgp router-id 172.16.2.1
bgp log-neighbor-changes
network 172.16.2.0 mask 255.255.255.0
network 172.16.22.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 13.13.13.1 remote-as 30
!
hostname R3
!
interface Loopback0
ip address 172.16.33.1 255.255.255.0
!
interface Loopback1
ip address 172.16.3.1 255.255.255.0
!
interface Ethernet0/0
ip address 13.13.13.1 255.255.255.252
no shut
!
interface Ethernet0/1
ip address 14.14.14.2 255.255.255.252
no shut
!
router bgp 30
bgp router-id 172.16.3.1
bgp log-neighbor-changes
network 172.16.3.0 mask 255.255.255.0
network 172.16.33.0 mask 255.255.255.0
neighbor 13.13.13.2 remote-as 10
!
hostname R5
!
interface Loopback0
ip address 172.16.5.1 255.255.255.0
!
interface Loopback1
ip address 172.16.55.1 255.255.255.0
!
interface Ethernet0/0
ip address 14.14.14.2 255.255.255.252
duplex auto
!
interface Ethernet0/1
no ip address
shutdown
duplex auto
!
interface Ethernet0/2
no ip address
shutdown
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
router bgp 40
bgp log-neighbor-changes
network 172.16.5.0 mask 255.255.255.0
network 172.16.55.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 10
!
hostname R4
!
interface Ethernet0/0
ip address 12.12.12.2 255.255.255.252
ip ospf network point-to-point
ip ospf 1 area 0
duplex auto
!
interface Ethernet0/1
ip address 15.15.15.2 255.255.255.252
ip ospf network point-to-point
ip ospf 1 area 0
exit
!
router ospf 1
!
interface Loopback0
ip address 10.1.1.4 255.255.255.255
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
ip address 172.16.11.1 255.255.255.0
!
interface Ethernet0/0
ip address 12.12.12.1 255.255.255.252
ip ospf network point-to-point
no shut
!
interface Ethernet0/2
ip address 14.14.14.1 255.255.255.252
no shut
!
router ospf 1
network 12.12.12.0 0.0.0.3 area 0
!
router bgp 10
bgp router-id 172.16.1.1
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.0
network 172.16.11.0 mask 255.255.255.0
neighbor 14.14.14.2 remote-as 40
neighbor 15.15.15.1 remote-as 10
!
hostname R2
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface Loopback1
ip address 172.16.22.1 255.255.255.0
!
interface Ethernet0/0
ip address 15.15.15.1 255.255.255.252
ip ospf network point-to-point
duplex auto
!
interface Ethernet0/1
ip address 13.13.13.2 255.255.255.252
duplex auto
!
router ospf 1
network 15.15.15.0 0.0.0.3 area 0
!
router bgp 10
bgp router-id 172.16.2.1
bgp log-neighbor-changes
network 172.16.2.0 mask 255.255.255.0
network 172.16.22.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 13.13.13.1 remote-as 30
!
hostname R3
!
interface Loopback0
ip address 172.16.33.1 255.255.255.0
!
interface Loopback1
ip address 172.16.3.1 255.255.255.0
!
interface Ethernet0/0
ip address 13.13.13.1 255.255.255.252
no shut
!
interface Ethernet0/1
ip address 14.14.14.2 255.255.255.252
no shut
!
router bgp 30
bgp router-id 172.16.3.1
bgp log-neighbor-changes
network 172.16.3.0 mask 255.255.255.0
network 172.16.33.0 mask 255.255.255.0
neighbor 13.13.13.2 remote-as 10
!
hostname R5
!
interface Loopback0
ip address 172.16.5.1 255.255.255.0
!
interface Loopback1
ip address 172.16.55.1 255.255.255.0
!
interface Ethernet0/0
ip address 14.14.14.2 255.255.255.252
duplex auto
!
interface Ethernet0/1
no ip address
shutdown
duplex auto
!
interface Ethernet0/2
no ip address
shutdown
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
router bgp 40
bgp log-neighbor-changes
network 172.16.5.0 mask 255.255.255.0
network 172.16.55.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 10
!
hostname R4
!
interface Ethernet0/0
ip address 12.12.12.2 255.255.255.252
ip ospf network point-to-point
ip ospf 1 area 0
duplex auto
!
interface Ethernet0/1
ip address 15.15.15.2 255.255.255.252
ip ospf network point-to-point
ip ospf 1 area 0
exit
!
router ospf 1
!
interface Loopback0
ip address 10.1.1.4 255.255.255.255
!
LALU TAMBHKAN KONFIGURASI BERIKUT INI
R1
route-map ACL-20 permit 10
match ip address 20
!
route-map ACL-10 permit 10
match ip address 10
!
access-list 10 permit 172.16.5.0 0.0.0.255
access-list 10 permit 172.16.55.0 0.0.0.255
!
access-list 20 permit 12.12.12.0 0.0.0.3
access-list 20 permit 15.15.15.0 0.0.0.3
!
match ip address 20
!
route-map ACL-10 permit 10
match ip address 10
!
access-list 10 permit 172.16.5.0 0.0.0.255
access-list 10 permit 172.16.55.0 0.0.0.255
!
access-list 20 permit 12.12.12.0 0.0.0.3
access-list 20 permit 15.15.15.0 0.0.0.3
!
router bgp 10
synchronization
redistribute ospf 1 route-map ACL-20
synchronization
redistribute ospf 1 route-map ACL-20
!
router ospf 1
redistribute connected subnets
redistribute bgp 10 subnets route-map ACL-10
!
R2
router ospf 1
redistribute connected subnets
redistribute bgp 10 subnets route-map ACL-10
!
R2
router ospf 1
redistribute connected subnets
!
router bgp 10
synchronization
VERIFIKASI:
redistribute connected subnets
!
router bgp 10
synchronization
VERIFIKASI:
Posting Komentar untuk "Cisco | BGP - Synchronization"