Lompat ke konten Lompat ke sidebar Lompat ke footer

Cisco | BGP - Mindah Jalur - Local Preference

 












LOCAL PREFERENCE adalah merupakan atribut yg diterapkan dijalur keluar router. Local Preference akan diterukan kedalam router iBGP saat mengirim update infromasi routing. Tugasnya akan menginformasikan ke router BGP bagaimana memili jalur ke luar AS jika terdapat beberapa jalur. Nilai (value) Local Preference yang paling besar akan dipiliha sebagai jalur terbaik. Default Local Preference adalah 100.

Konfigurasi Masing-Masing Router
hostname R1
interface gi0/0
ip address 21.21.21.1 255.255.255.0
no sh
exit

default interface gi0/1
interface gi0/1
ip address 20.20.20.1 255.255.255.0
no sh
exit

interface gi0/2
ip address 192.168.1.254 255.255.255.0
no sh
exit

int loo0
ip address 1.1.1.1 255.255.255.255
exit

no router bgp 123
router bgp 50
network 1.1.1.1 mask 255.255.255.255
network 192.168.1.0 mask 255.255.255.0
neighbor 20.20.20.4 remote-as 123
neighbor 21.21.21.5 remote-as 123
network 20.20.20.0 mask 255.255.255.0 # additional
exit

hostname R2
interface gi0/0
ip address 12.12.12.2 255.255.255.0
no sh
exit

interface gi0/2
ip address 14.14.14.2 255.255.255.0
no sh
exit

interface gi0/3
ip address 50.50.50.2 255.255.255.0
no sh
exit

int loo0
ip address 2.2.2.2 255.255.255.255
exit

router ospf 100
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.10.2 0.0.0.0 area 0
 network 50.50.50.2 0.0.0.0 area 0
 network 14.14.14.2 0.0.0.0 area 0
 exit

router bgp 123
bgp router-id 2.2.2.2
neighbor 12.12.12.4 remote-as 40
 neighbor 100.100.100.100 update-source Loopback0
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 next-hop-self #additional
 exit

#tambahan jika, advertise loo1 ke bgp di R2
int loop1
ip add 22.22.22.22 255.255.255.255
exit

router bgp 123
address-family ipv4
network 22.22.22.22 mask 255.255.255.255

hostname R3
default interface gi0/0
interface gi0/0
ip address 13.13.13.3 255.255.255.0
no sh
exit

default interface gi0/2
interface gi0/2
ip address 14.14.14.3 255.255.255.0
no sh
exit

default interface gi0/3
interface gi0/3
ip address 52.52.52.3 255.255.255.0
no sh
exit

int loo0
ip address 3.3.3.3 255.255.255.255
exit

router ospf 100
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 14.14.14.3 0.0.0.0 area 0
 network 52.52.52.3 0.0.0.0 area 0
 exit

router bgp 123
 bgp router-id 3.3.3.3
 neighbor 13.13.13.4 remote-as 40
 neighbor 100.100.100.100 remote-as 123
 neighbor 100.100.100.100 update-source Loopback0
 neighbor 100.100.100.100 activate
 
neighbor 100.100.100.100 next-hop-self #additional
 exit

hostname R4

default interface gi0/1
interface gi0/1
ip address 20.20.20.4 255.255.255.0
no sh
exit

default interface gi0/2
interface gi0/2
ip address 15.15.15.4 255.255.255.0
no sh
exit

default interface gi0/3
interface gi0/3
ip address 51.51.51.4 255.255.255.0
no sh
exit

int loo0
ip address 4.4.4.4 255.255.255.255
exit

router ospf 100
 router-id 4.4.4.4
 network 4.4.4.4 0.0.0.0 area 0
 network 15.15.15.4 0.0.0.0 area 0
 network 51.51.51.4 0.0.0.0 area 0
 exit

router bgp 123
 bgp router-id 4.4.4.4
 neighbor 20.20.20.1 remote-as 50
 neighbor 100.100.100.100 remote-as 123
 neighbor 100.100.100.100 update-source Loopback0
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 next-hop-self #additional
 exit

hostname R5
interface gi0/1
ip address 21.21.21.5 255.255.255.0
no sh
exit

interface gi0/2
ip address 15.15.15.5 255.255.255.0
no sh
exit

interface gi0/3
ip address 53.53.53.5 255.255.255.0
no sh
exit

int loo0
ip address 5.5.5.5 255.255.255.255
exit

router ospf 100
 router-id 5.5.5.5
 network 5.5.5.5 0.0.0.0 area 0
 network 15.15.15.5 0.0.0.0 area 0
 network 53.53.53.5 0.0.0.0 area 0
 exit

router bgp 123
 bgp router-id 5.5.5.5
 neighbor 21.21.21.1 remote-as 50
 neighbor 100.100.100.100 remote-as 123
 neighbor 100.100.100.100 update-source Loopback0
 neighbor 100.100.100.100 activate
 
neighbor 100.100.100.100 next-hop-self #additional
 exit

hostname RR
interface gi0/0
ip address 53.53.53.1 255.255.255.0
no sh
exit

interface gi0/1
ip address 50.50.50.1 255.255.255.0
no sh
exit

interface gi0/2
ip address 51.51.51.1 255.255.255.0
no sh
exit

interface gi0/3
ip address 52.52.52.1 255.255.255.0
no sh
exit

int loo0
ip address 100.100.100.100 255.255.255.255
exit

router ospf 100
 router-id 100.100.100.100
 network 100.100.100.100 0.0.0.0 area 0
 network 50.50.50.1 0.0.0.0 area 0
 network 51.51.51.1 0.0.0.0 area 0
 network 52.52.52.1 0.0.0.0 area 0
 network 53.53.53.1 0.0.0.0 area 0
 exit

router bgp 123
 bgp router-id 100.100.100.100
 neighbor iBGP peer-group
 neighbor iBGP remote-as 123
 neighbor iBGP update-source Loopback0
 neighbor iBGP route-reflector-client

 neighbor 2.2.2.2 peer-group iBGP
 neighbor 3.3.3.3 peer-group iBGP
 neighbor 4.4.4.4 peer-group iBGP
 neighbor 5.5.5.5 peer-group iBGP

hostname R6
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
exit

interface Loopback1
 ip address 8.8.4.4 255.255.255.255
exit

interface Loopback2
 ip address 172.16.10.1 255.255.255.255
exit

interface Loopback3
 ip address 172.16.20.1 255.255.255.255
exit

interface GigabitEthernet0/0
 ip address 12.12.12.4 255.255.255.0
 no shut
exit

interface GigabitEthernet0/1
 ip address 13.13.13.4 255.255.255.0
 no shu
 exit

router bgp 40
network 8.8.4.4 mask 255.255.255.255
network 8.8.8.8 mask 255.255.255.255
network 172.16.10.1 mask 255.255.255.255 #Loop2 Addtional
network 172.16.20.1 mask 255.255.255.255 #Loop3 Addtional
neighbor 13.13.13.3 remote-as 123
neighbor 12.12.12.2 remote-as 123

Verifikasi:
Dari hasil verifkasi untuk menuju IP loopback di R6 best-pathnya adalah 2.2.2.2 yaitu R2.














Sekarang kita akan ubah jalurnya, dari R6 dengan source  IP 8.8.8.8 dan 8.8.4.4 menuju RR jalurnya dipaksa melalui R3. Artinya R6 akan membaca jalur terbaik  dengan IP  8.8.8 dan 4.4.4.4 yg akan diadvertise (turun) ke AS 123 adalah melewati router R3.
Berikut konfigurasi atribut di R3
Router R3

ip access-list standard ACL_GOOGLE
permit host 8.8.8.8
permit host 8.8.4.4
exit
!
route-map WEIGHT_GOOGLE permit 10
 match ip address ACL_GOOGLE
 set local-preference 201
exit
!
router bgp 123
neighbor 13.13.13.4 route-map WEIGHT_GOOGLE in
exit


Verifikasi
:
Verifkasi lg di router RR bahwa menuju 8.8.8.8, 8.8.4.4 jalur terbaik adalah 13.13.13.4 sedangkan jika menuju 12.16.10.1 dan 172.16.20.1 adalah lewat R2 (2.2.2.2)










Perhatiakn gambar dibawah dari hasil verfikasi dgn traceroute dari R1 ke R6, maka best-path , ada yg dari R3 dan ada yg R2.

 

 

 

 

 

 

 

 


Dari hasil traceroute di R1, ke ip loopback R6 sdh punya jalur masing-masing
Success..!!!







Posting Komentar untuk "Cisco | BGP - Mindah Jalur - Local Preference"