Lompat ke konten Lompat ke sidebar Lompat ke footer

Cisco | L2VPN - Tag VLAN 10, 20 (New)

 

Step 1: Konfig IP Address

host P1
int lo0
ip add 1.1.1.1 255.255.255.255
exi
int gi0/0
no shu
 ip add 11.11.11.1 255.255.255.0
 exi

int gi0/1
 no ip add
 no shu
 ip add 12.12.12.1 255.255.255.0
 exi

int gi0/2
 no shu
 no ip add
 ip add 14.14.14.1 255.255.255.0
 exi

Router P2
host P2
int lo0
ip add 2.2.2.2 255.255.255.255
exi

int gi0/0
 no ip add
 ip add 12.12.12.2 255.255.255.0
 exi

int gi0/1
 no shu
 no ip add
 ip add 13.13.13.2 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 15.15.15.1 255.255.255.0
 exi

Router P3
host P3
int lo0
ip add 3.3.3.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 11.11.11.3 255.255.255.0
 exi

int gi0/1
 no shu
 ip add 13.13.13.3 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 16.16.16.1 255.255.255.0
 exi


host PE1

int lo0
ip add 10.0.0.1 255.255.255.255
exi

int gi0/0
 no shu
 ip add 14.14.14.2 255.255.255.0
 exi


host PE2
int lo0
ip add 10.0.0.2 255.255.255.255
exi

int gi0/0
 no shu
 ip add 15.15.15.2 255.255.255.0
 exi

host PE3
int lo0
ip add 10.0.0.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 16.16.16.2 255.255.255.0
 exi

Step 2 : Konfig OSPF Routing (P1,P2,P3, PE1, PE2, PE1)

Router P1
router ospf 1
net 11.11.11.1 0.0.0.0 are 0
net 14.14.14.1 0.0.0.0 are 0
net 12.12.12.1 0.0.0.0 are 0
net 1.1.1.1 0.0.0.0 are 0
exi

Router P2
router ospf 1
net 12.12.12.2 0.0.0.0 are 0
net 13.13.13.2 0.0.0.0 are 0
net 15.15.15.1 0.0.0.0 are 0
net 2.2.2.2 0.0.0.0 are 0
exi

Router P3
router ospf 1
net 13.13.13.3 0.0.0.0 are 0
net 16.16.16.1 0.0.0.0 are 0
net 11.11.11.3 0.0.0.0 are 0
net 3.3.3.3 0.0.0.0 are 0
exi

Router PE1
router ospf 1
net 14.14.14.2 0.0.0.0 are 0
net 10.0.0.1 0.0.0.0 are 0
exi

Router PE2
router ospf 1
net 15.15.15.2 0.0.0.0 are 0
net 10.0.0.2 0.0.0.0 are 0
exi

Router PE3
router ospf 1
net 16.16.16.2 0.0.0.0 are 0
net 10.0.0.3 0.0.0.0 are 0
exi

Step 3 : (Aktifkan MPLS
label di  router ISP area yaitu: (P1,P2,P3, PE1, PE2 dan PE3)

Router P1
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exi

Router P2

mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exi

Router P3
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exit

Router PE1
mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Router PE2

mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi


Router PE3

mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi


Verifkasi:
#sh mpls ldp neighbor
#sh mpls forwarding-table
P1#show mpls forwarding-table 10.0.0.1

Step 4: Konfig xconnect antar router PE dengan tagged VLAN 10, VLAN 20 pd router PE1, PE2 dan PE3

Router PE1
pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.10
 encapsulation dot1q 10
 desc 'Link to BCA-3"
 no shu
 xconnect 10.0.0.3 45 encapsulation mpls pw-class PW-CE-BCA
  exi
  exit

pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
 encapsulation dot1q 20
 no shu
 desc 'LINK TO BRI-3"
 xconnect 10.0.0.3 100 encapsulation mpls pw-class PW-CE-BRI
 exit

Router  PE2
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
desc 'Link to BRI-1"
encapsulation dot1q 20
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 exit

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.20
encapsulation dot1q 20
 no shu
 desc 'Link to BRI-3"
 xconnect 10.0.0.3 100 encapsulation mpls pw-class PW-CE-BRI
 ex

Router PE3
Konfigurasi PE3
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2.20
encapsulation dot1q 20
desc 'Link to BRI-1"
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 exi
exit

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1.10
encapsulation dot1q 10
 no shu
 desc 'Link to BCA-1"
 xconnect 10.0.0.1 45 encapsulation mpls pw-class PW-CE-BCA
 ex
 exit

VERIFIKASI:
PE1
#do sh run | sec pse
#ping mpls pseudowire 10.0.0.3 100
#ping mpls pseudowire 10.0.0.3 45

Step 5: Konfig IP interface VLAN router (BCA-1, BCA-2 dan Switch SW-BRI-2 DAN SW-BRI-1

Router BCA-1

host BCA-1
interface gi0/0.10
 encapsulation dot1q 10
 ip address 10.28.10.1 255.255.255.0
 no shu
 exi

interface gi0/1
ip address 172.16.10.1 255.255.255.0
no shut
exit

ip route 172.16.20.0 255.255.255.0 10.28.10.1

Router BCA-3
host BCA-2
interface gi0/0.10
encapsulation dot1q 10
 ip address 10.28.10.3 255.255.255.0
 no shu
 exi

interface gi0/1
ip address 172.16.20.1 255.255.255.0
no shut
exit

ip route 172.16.10.0 255.255.255.0 10.28.10.1

VERIFKASI
BCA-1
ping 10.28.10.3
BCA-3
ping 10.28.10.1
dan

PING ANTAR user-BCA sblh kiri ke user-BCA kanan. Harusnya sdh reply

 

KONFIGURASI SWITCH SW-BRI-1 dan SW-BRI-2

SWITCH SW-BRI-1
ena
conf t
host SW-BRI-1
vlan 10
vlan 20
int gi0/0
switch trunk encap do1q
switch mode trunk
exit

int gi0/1
switch mode acc
switch access vlan 10
exit

int gi0/2
switch mode acc
switch access vlan 20
exit

SWITCH SW-BRI-2
ena
conf t
host SW-BRI-2   
vlan 10
vlan 20
int gi0/0
switch trunk encap do1q
switch mode trunk
exit

int gi0/1
switch mode acc
switch access vlan 10
exit

int gi0/2
switch mode acc
switch access vlan 20
exit

VERIFKASI
PC-BRI-3
ping 192.168.1.1

PC-BRI-1
ping 192.168.1.2

harusnys sdh reply ...

Posting Komentar untuk "Cisco | L2VPN - Tag VLAN 10, 20 (New)"