Lompat ke konten Lompat ke sidebar Lompat ke footer

Cisco | MPLS - L2VPN - Ecapsulation - Untagged Frame

Step-1 : (Konfigurasi IP address di semua router yaitu di router P1, P2, P3, PE1, PE2 dan PE3)

Router P2
host P1
int lo0
ip add 1.1.1.1 255.255.255.255
exi
int gi0/0
no shu
 no ip add 111.11.11.1 255.255.255.0
 ip add 11.11.11.1 255.255.255.0
 exi

int gi0/1
 no ip add
 no shu
 ip add 12.12.12.1 255.255.255.0
 exi

int gi0/2
 no shu
 no ip add
 ip add 14.14.14.1 255.255.255.0
 exi

--------
Router P2
host P2
int lo0
ip add 2.2.2.2 255.255.255.255
exi

int gi0/0
 no ip add


 ip add 12.12.12.2 255.255.255.0
 exi

int gi0/1
 no shu
 no ip add
 ip add 13.13.13.2 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 15.15.15.1 255.255.255.0
 exi

----------
Router P3
host P3
int lo0
ip add 3.3.3.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 11.11.11.3 255.255.255.0
 exi

int gi0/1
 no shu
 ip add 13.13.13.3 255.255.255.0
 exi

int gi0/2
 no shu
 ip add 16.16.16.1 255.255.255.0
 exi
===================================
Konfigurasi  Router PE1

host PE1
int lo0
ip add 10.0.0.1 255.255.255.255
exi

int gi0/0
 no shu
 ip add 14.14.14.2 255.255.255.0
 exi

-----------

Konfigurasi  Router PE2

host PE2
int lo0
ip add 10.0.0.2 255.255.255.255
exi

int gi0/0
 no shu
 ip add 15.15.15.2 255.255.255.0
 exi

-------------

Konfigurasi  Router PE3
host PE3
int lo0
ip add 10.0.0.3 255.255.255.255
exi

int gi0/0
 no shu
 ip add 16.16.16.2 255.255.255.0
 exi

Step 2 : (Advertise network dengan routing OSPF) (Router P1,P2,P3, PE1, PE2, PE3 )

Router P1
router ospf 1
net 11.11.11.1 0.0.0.0 are 0
net 14.14.14.1 0.0.0.0 are 0
net 12.12.12.1 0.0.0.0 are 0
net 1.1.1.1 0.0.0.0 are 0
exi
---------------
Router P2
router ospf 1
net 12.12.12.2 0.0.0.0 are 0
net 13.13.13.2 0.0.0.0 are 0
net 15.15.15.1 0.0.0.0 are 0
net 2.2.2.2 0.0.0.0 are 0
exi
do wr

Router P3
router ospf 1
net 13.13.13.3 0.0.0.0 are 0
net 16.16.16.1 0.0.0.0 are 0
net 11.11.11.3 0.0.0.0 are 0
net 3.3.3.3 0.0.0.0 are 0
exi

Router PE1
router ospf 1
net 14.14.14.2 0.0.0.0 are 0
net 10.0.0.1 0.0.0.0 are 0
exi

Router PE2
router ospf 1
net 15.15.15.2 0.0.0.0 are 0
net 10.0.0.2 0.0.0.0 are 0
exi

Router PE3
router ospf 1
net 16.16.16.2 0.0.0.0 are 0
no net 10.0.0.1 0.0.0.0 are 0
net 10.0.0.3 0.0.0.0 are 0
exi

Step 3 :Konfigurasi MPLS di  ISP area yaitu: (P1,P2,P3, PE1, PE2 dan PE3)

Router P1
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip

Router P2
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
exi

Router P3
mpls label protocol ldp
mpls ldp router-id lo0 force

int range gi0/0-2
mpls ip
exit

Router PE1
mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Router PE2

mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Router PE3
mpls label protocol ldp
mpls ldp router-id lo0 force

int gi0/0
mpls ip
exi

Verifkasi:
#sh mpls ldp neighbor
#sh mpls forwarding-table







Step 4: Terahir kita konfigurasikan xconnect antar router PE (router PE1, PE2 dan PE3)

Konfigurasi PE1
pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit


interface gi0/1
 desc 'LINK TO BCA-2"
 no shu
 xconnect 10.0.0.3 45 encapsulation mpls pw-class PW-CE-BCA
  exi

pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit


interface gi0/2
 no shu
 desc 'LINK TO BRI-2"
 xconnect 10.0.0.3 100 encapsulation mpls pw-class PW-CE-BRI
 exit

Konfigurasi PE2
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit


interface gi0/2
desc 'LINK TO BRI-1"
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 exit

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1
 no shu
 desc 'LINK TO BCA-1"
 xconnect 10.0.0.1 45 encapsulation mpls pw-class PW-CE-BRCA
 ex

Konfigurasi PE3
pseudowire-class PW-CE-BRI
 encapsulation mpls
 exit

interface gi0/2
desc 'LINK TO BRI-1"
 no shu
 xconnect 10.0.0.1 100 encapsulation mpls pw-class PW-CE-BRI
 ex

pseudowire-class PW-CE-BCA
 encapsulation mpls
 exit

interface gi0/1
 no shu
 desc 'LINK TO BCA-1"
 xconnect 10.0.0.1 45 encapsulation mpls pw-class PW-CE-BCA
 ex

VERIFIKASI:
PE1
#do sh run | sec
pseudowire
#ping mpls pseudowire 10.0.0.3 100
#ping mpls pseudowire 10.0.0.3 45

Verifikasi::
DI PE1
# ping mpls pseudowire 10.0.0.3 100
# ping mpls pseudowire 10.0.0.3 45

Step 6: Tahap terahir. Konfigurasi  IP address router (BCA-1, BCA-2, BRI-1, dan BRI-2) menggunakan ip yang satu segment   antara BRI-1 dengan BRI-2 dan segment yg sama juga antar BCA-1 dgn BCA-2.

Router BCA-1
host BCA-1
interface gi0/0
 ip address 10.28.10.1 255.255.255.0
 no shu
 exi

Router BCA-2
host BCA-2
interface gi0/0
 ip address 10.28.10.2 255.255.255.0
 no shu
 exi

Router BRI-1

host BRI-1
interface gi0/2
 ip address 192.168.1.1 255.255.255.0
 no shu
 exi

Router BRI-2
host BRI-2
interface gi0/0
 ip address 192.168.1.2 255.255.255.0
 no shu
 exi


Verifikasi : Apakah sdh reachable natar BCA1 dgn BCA2 dan BRI1 dgn BRI2 ?. Ahirnya sukses..!!!









VERIFIKASI:
Lakukan ping antar PC-BRI-1  dengan PC-BRI-2. Klo replay, berrarti sdh conected. Done










Posting Komentar untuk "Cisco | MPLS - L2VPN - Ecapsulation - Untagged Frame"