OSPF-Advanced Routing (Type LSA dan Special Area)
Kali ini kita akan membahas routing protocol OSPF, dan fokus kita adalah mengenai link state advertisement dan specila area. Sebelum kita masuk ke pembahasan, pastikan semua network sudah reachable antar semua router.
Konfigurasi di masing-masing Router
hostname R1
clock timezone WIB 7
int gi0/0
ip add 10.1.2.1 255.255.255.252
no shut
int gi0/1
ip add 10.1.1.1 255.255.255.252
no shut
int lo0
ip add 172.16.1.1 255.255.255.255
no shut
int gi0/2
ip add 192.168.0.1 255.255.255.0
ip add 192.168.1.1 255.255.255.0 secondary
ip add 192.168.2.1 255.255.255.0 secondary
ip add 192.168.3.1 255.255.255.0 secondary
no shut
descrip "External Network 192.168.0.0/22"
no shut
router ospf 1
router-id 172.16.1.1
network 10.1.1.0 0.0.0.3 area 12
network 10.1.2.0 0.0.0.3 area 12
network 172.16.1.1 0.0.0.0 area 12
passive-interface gi0/1
end
--
hostname R2
clock timezone WIB 7
int lo0
ip add 172.16.2.2 255.255.255.255
no shut
int gi0/0
ip add 10.1.2.2 255.255.255.252
no shut
int gi0/1
ip add 10.2.3.1 255.255.255.252
no shut
int gi0/2
ip add 10.2.4.1 255.255.255.252
no shut
router ospf 2
router-id 172.16.2.2
network 10.2.3.0 0.0.0.3 area 0
network 10.2.4.0 0.0.0.3 area 0
network 10.1.2.0 0.0.0.3 area 12
network 172.16.2.2 0.0.0.0 area 12
end
----
hostname R3
clock timezone WIB 7
int lo0
ip add 172.16.3.3 255.255.255.255
no shut
int gi0/1
ip add 10.3.5.1 255.255.255.252
no shut
int gi0/0
ip add 10.2.3.2 255.255.255.252
no shut
int gi0/2
ip add 10.3.4.1 255.255.255.252
no shut
int gi0/3
ip add 172.16.31.1 255.255.255.192
ip add 172.16.31.65 255.255.255.192 secondary
ip add 172.16.31.129 255.255.255.192 secondary
ip add 172.16.31.193 255.255.255.192 secondary
no shut
descrip "External Network"
no shut
router ospf 3
router-id 172.16.3.3
network 10.2.3.0 0.0.0.3 area 0
network 10.3.5.0 0.0.0.3 area 0
network 10.3.4.0 0.0.0.3 area 0
network 172.16.3.3 0.0.0.0 area 0
end
--
hostname R4
clock timezone WIB 7
int lo0
ip add 172.16.4.4 255.255.255.255
no shut
int gi0/1
ip add 10.4.5.1 255.255.255.252
no shut
int gi0/0
ip add 10.2.4.2 255.255.255.252
no shut
int gi0/2
ip add 10.3.4.2 255.255.255.252
no shut
router ospf 4
router-id 172.16.4.4
network 10.2.4.0 0.0.0.3 area 0
network 10.4.5.0 0.0.0.3 area 0
network 10.3.4.0 0.0.0.3 area 0
network 172.16.4.4 0.0.0.0 area 0
end
--
hostname R5
clock timezone WIB 7
int lo0
ip add 172.16.5.5 255.255.255.255
no shut
int gi0/0
ip add 10.4.5.2 255.255.255.252
no shut
int gi0/1
ip add 10.3.5.2 255.255.255.252
no shut
int gi0/2
ip add 10.5.6.1 255.255.255.252
no shut
int loo1
ip add 172.6.5.5 255.255.255.255
no shu
router ospf 5
router-id 172.16.5.5
network 10.5.6.0 0.0.0.3 area 56
network 10.4.5.0 0.0.0.3 area 0
network 10.3.5.0 0.0.0.3 area 0
network 172.16.5.5 0.0.0.0 area 56
end
--
hostname R6
clock timezone WIB 7
int gi0/1
ip add 10.6.6.1 255.255.255.252
no shut
int gi0/0
ip add 10.5.6.2 255.255.255.252
no shut
int lo0
ip add 172.16.6.6 255.255.255.255
no shu
router ospf 6
router-id 172.16.6.6
network 10.5.6.0 0.0.0.3 area 56
network 10.6.6.0 0.0.0.3 area 56
network 172.16.6.6 0.0.0.0 area 56
passive-interface gi0/1
end
VERIFIKASI
#sh ip protocol
#sh ip ospf
#sh ip ospf interface [gi0/0]
#sh ip route
#sh ip os
#sh ip ospf neighbor
#sh ip ospf database
-----------------------------
Proese ID itu dari 1-65.ribu
IA artinya dari area lain
Type-type LSA
LSA Type-1:
LSA Type-2:
R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip ospf network pint-to-point.
LSA Type 3.
LSA Type 4
ASBR Summary, yang menggenarate adalah router ABR dan memberitahu ke area lain bahwa tetangga saya punya ASBR. Yg meng-advertise adalah router ABR pada are tersebut.
LSA Type 5
Catatan:
Redistribute type E2 = metrik 20 dan tdk beribah sampe ke ruter brapa pun
Redistribute type E1 = metrik 20 ditambah interface cost
Refrence BW disarankan diubah menjadi setara dgn nilai BW terbesar di jairngan kita. Misal ada BW interface 10G, maka Refrence BW = 10000
Caranya:
#router ospf 1
#auto-cost refrence-bandwitdh 10000
Verifkasi/ceh refrence BW
#sh ip ospf
clock timezone WIB 7
int gi0/0
ip add 10.1.2.1 255.255.255.252
no shut
int gi0/1
ip add 10.1.1.1 255.255.255.252
no shut
int lo0
ip add 172.16.1.1 255.255.255.255
no shut
int gi0/2
ip add 192.168.0.1 255.255.255.0
ip add 192.168.1.1 255.255.255.0 secondary
ip add 192.168.2.1 255.255.255.0 secondary
ip add 192.168.3.1 255.255.255.0 secondary
no shut
descrip "External Network 192.168.0.0/22"
no shut
router ospf 1
router-id 172.16.1.1
network 10.1.1.0 0.0.0.3 area 12
network 10.1.2.0 0.0.0.3 area 12
network 172.16.1.1 0.0.0.0 area 12
passive-interface gi0/1
end
--
hostname R2
clock timezone WIB 7
int lo0
ip add 172.16.2.2 255.255.255.255
no shut
int gi0/0
ip add 10.1.2.2 255.255.255.252
no shut
int gi0/1
ip add 10.2.3.1 255.255.255.252
no shut
int gi0/2
ip add 10.2.4.1 255.255.255.252
no shut
router ospf 2
router-id 172.16.2.2
network 10.2.3.0 0.0.0.3 area 0
network 10.2.4.0 0.0.0.3 area 0
network 10.1.2.0 0.0.0.3 area 12
network 172.16.2.2 0.0.0.0 area 12
end
----
hostname R3
clock timezone WIB 7
int lo0
ip add 172.16.3.3 255.255.255.255
no shut
int gi0/1
ip add 10.3.5.1 255.255.255.252
no shut
int gi0/0
ip add 10.2.3.2 255.255.255.252
no shut
int gi0/2
ip add 10.3.4.1 255.255.255.252
no shut
int gi0/3
ip add 172.16.31.1 255.255.255.192
ip add 172.16.31.65 255.255.255.192 secondary
ip add 172.16.31.129 255.255.255.192 secondary
ip add 172.16.31.193 255.255.255.192 secondary
no shut
descrip "External Network"
no shut
router ospf 3
router-id 172.16.3.3
network 10.2.3.0 0.0.0.3 area 0
network 10.3.5.0 0.0.0.3 area 0
network 10.3.4.0 0.0.0.3 area 0
network 172.16.3.3 0.0.0.0 area 0
end
--
hostname R4
clock timezone WIB 7
int lo0
ip add 172.16.4.4 255.255.255.255
no shut
int gi0/1
ip add 10.4.5.1 255.255.255.252
no shut
int gi0/0
ip add 10.2.4.2 255.255.255.252
no shut
int gi0/2
ip add 10.3.4.2 255.255.255.252
no shut
router ospf 4
router-id 172.16.4.4
network 10.2.4.0 0.0.0.3 area 0
network 10.4.5.0 0.0.0.3 area 0
network 10.3.4.0 0.0.0.3 area 0
network 172.16.4.4 0.0.0.0 area 0
end
--
hostname R5
clock timezone WIB 7
int lo0
ip add 172.16.5.5 255.255.255.255
no shut
int gi0/0
ip add 10.4.5.2 255.255.255.252
no shut
int gi0/1
ip add 10.3.5.2 255.255.255.252
no shut
int gi0/2
ip add 10.5.6.1 255.255.255.252
no shut
int loo1
ip add 172.6.5.5 255.255.255.255
no shu
router ospf 5
router-id 172.16.5.5
network 10.5.6.0 0.0.0.3 area 56
network 10.4.5.0 0.0.0.3 area 0
network 10.3.5.0 0.0.0.3 area 0
network 172.16.5.5 0.0.0.0 area 56
end
--
hostname R6
clock timezone WIB 7
int gi0/1
ip add 10.6.6.1 255.255.255.252
no shut
int gi0/0
ip add 10.5.6.2 255.255.255.252
no shut
int lo0
ip add 172.16.6.6 255.255.255.255
no shu
router ospf 6
router-id 172.16.6.6
network 10.5.6.0 0.0.0.3 area 56
network 10.6.6.0 0.0.0.3 area 56
network 172.16.6.6 0.0.0.0 area 56
passive-interface gi0/1
end
VERIFIKASI
#sh ip protocol
#sh ip ospf
#sh ip ospf interface [gi0/0]
#sh ip route
#sh ip os
#sh ip ospf neighbor
#sh ip ospf database
-----------------------------
Proese ID itu dari 1-65.ribu
IA artinya dari area lain
Type-type LSA
LSA Type-1:
Namanya router LSA, LSA ini dibuat oleh semua router (digenrate) kemudian dikirim dalam satu area saja. Semua LSA akan mendapatkan LSA type diarea masing2, tdk akn nyebar ke area lain. Isinya adalah: Neighbor ID
LSA Type-2:
LSA type disebut network LSA dmana LSA ini dikirim oleh DR yang ada didalam satu area, dan siapa saja yg konek dalam satu area tersebut. Jika ada 5 DR dalam segment tersebut maka ada 5 LSA type 2. Ketika kt mengubah type nework PtoP maka LSA type2 tdk ada akan muncul di databsae LSA, Catatan: Jika link p2p baeknya type network diubah menjadi p2p saja, Tujunaya mempercepat convergensi.
Berikut perintanya (lakukan di R1 dan R2:R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip ospf network pint-to-point.
LSA Type 3.
LSA Summary yg didapt dari area lain yg dirangkum dalam satu LSA yg diadvertise oleh router ABR dan dilempar ke area lain. Ingat hanya router ABR yg meng-genarate summary LSA. Type 3 ini muncul ketika multi area, jika hanya singel area type 3 tdk muncul
LSA Type 4
ASBR Summary, yang menggenarate adalah router ABR dan memberitahu ke area lain bahwa tetangga saya punya ASBR. Yg meng-advertise adalah router ABR pada are tersebut.
Misal: R1 <----> R2. R1 sbg ASBR, dan R2 mendapat info bahwa R1 adalah ruter ASBR, lalu R2 mengenarete LSA type4 dan dilempar ke are lain, karena R2 jg sbg ABR (penghubung antar area).
Dan misalnya di R3 kita tambahkan network 172.16.31.0/24 lalu kita redistribute ke OSPF, maka jika kita verifikasi di R6 muncul menjadi dua LSA Type 4.
- Pertama dapat dari R2 bahwa R2 lempar ke area lain bahwa R1 sbgi ASBR, lalu R5 dapat info dari R2 dan diinfo ke R6
- Kedua, R6 dapat info dari R5 bahwa pada R3 dia juga sebagai ASBR
Ya mengenarate LSA type 5 ini dalah ASBR, dan dilempar kesemua are. isinya adalah external network/ hasil redistribute. Type 5 ini muncul jika ada ASBR.
Redistribute type E2 = metrik 20 dan tdk beribah sampe ke ruter brapa pun
Redistribute type E1 = metrik 20 ditambah interface cost
Refrence BW disarankan diubah menjadi setara dgn nilai BW terbesar di jairngan kita. Misal ada BW interface 10G, maka Refrence BW = 10000
Caranya:
#router ospf 1
#auto-cost refrence-bandwitdh 10000
Verifkasi/ceh refrence BW
#sh ip ospf
Spesial Area
1. Normal Area, area yang punya LSA type 1,2 3 4 dan 5
2. Stub Area. Area ini bisa mem-filter LSA type tertentu, tujuannya ntk menghemat resource di internal ruter. Syaratnya stub area adalah bukan area 0, dan tdk boleh ad ASBR, dan tdk boleh ada OSPF Virtual Link. LSA yg diperbolehkan hanya type 1,2 dan 3. Sedagkn type 4,5 dihilangkan dan diganti dengan default-route (0.0.0..0) oleh R5 dan di-informasikan ke R6.
Kita akan mengubah R5 dan R6 menjadi Stub Area.
R5(config)#router ospf 6
R5(config-router)#area 56 stub
R6(config)#router ospf 6
R6(config-router)#area 56 stub
Verifikasi di R6
3. Totally Stubby Area: pada Totally Stubby area hanya ada LSA Type 1,2 sisanya default route. LSA type 3 (summary) jg akan hilang dan O IA juga hilang, dimana ini didapat dari Inter-Area/area lain. Kita langsung saja di R5 dan R6 ubah menjadi Tottaly Stubby Area. Cukup perintahnya hanya menambahkan no-summary pada router ABR yaitu router R5
R5(config)#router ospf 6
R5(config-router)#area 56 stub no-summary
R6(config)#router ospf 6
R6(config-router)#area 56 stub
Verifkasi:
Perhatikan bahwa LSA database dan routing table sdh diringkas diganti dengan default route 0.0.0.0/0.
Namun demikian R6 tetap bisa ping ke R1,R2 dan seterusnya.
4. NSSA (Not So Stubby Area) : Stub Area yg minimal punya satu ASBR . LSA yang bisa masuk adalah LSA type 1,2,3 dan type 7, sedangkan 4,5 diubah menjadi default-route. LSA type 7 hanya ada pada NSSA.
Catatan. didalam NSSA:
Type 1 : Router dalamsatu area
Type 2: Jika ada DR/BDR
Type 3: O IA dari area lain
Type 7: dari ASBR yg digenerate oleh ABR
Selain itu, type 4,5 diubah menjadi default-route (0.0.0.0) yg dugenrate oleh router ABR / R2
Untuk Lab-nya:-
Tambahkan network di R3 lalu redistribute ke OSPF
int gi0/3
ip add 172.16.31.1 255.255.255.192
ip add 172.16.31.65 255.255.255.192 secondary
ip add 172.16.31.129 255.255.255.192 secondary
ip add 172.16.31.193 255.255.255.192 secondary
no shut
descrip "External Network"
no shut
router ospf 3
redistribute connected subnet
- Lalu di R2 dan R1 lakukan perintah ini: untk mengaktifkan NSSA di area 12
R1(config)#router ospf 1
R1(config-router)#area 12 nssa
R2(config)#router ospf 2
R2(config-router)#area 12 nssa default-information-originate
Verifikasi:
Artinya network ini yg ada di R3 telah diresditribute;
ip address 172.16.31.65 255.255.255.192 secondary
ip address 172.16.31.129 255.255.255.192 secondary
ip address 172.16.31.193 255.255.255.192 secondary
ip address 172.16.31.1 255.255.255.192
sampe di R1 dubah menjadi LSA type7 oleh R2 dengan kode default-route, dan juga routing table default route, karena R1--R2 area 12 nssa.
Klo kita simpulkan NSSA itu stub area minimal punya satu ASBR, dia punya LSA type 1,2, 3 dan 7/default-route.
5. Totally NSSA
Ketika kita ubah menjadi Totally NSSA, maka yg masuk ke area 12 maka yg masuk LSA type 1,2 dan LSA type 7 + default route. LSA type 3 sdh hilang dan diganti dengan default-route.
jadi klo NSSA maka LSA type 3 (summary) mash ada, sdgkan Totally NSSA type 3 ini sdh hilang dan dganti ke default-route.
jadi klo NSSA maka LSA type 3 (summary) mash ada, sdgkan Totally NSSA type 3 ini sdh hilang dan dganti ke default-route.
Sebelum kita ubah ke Type Totally NSSA perhatikan databse dan routing table, dan nanti ita bisa lihat perbedaanya.
Lalu kita aktifkan perintah Totally NSSA di area 12.
R1(config)#router ospf 1
R1(config-router)#area 12 nssa
Posting Komentar untuk "OSPF-Advanced Routing (Type LSA dan Special Area)"