Cisco | BGP - Multihoming - ISP Berbeda (Load Sharing)
Kali ini kita akan mebahas melakukan load sharing
dengan menggunakan 2 ISP yang berbeda pada BGP dengan AS number yang
berbeda. Kita asumsikan R2 adalah ISP-1 dan R3 adalah ISP-2. Kita
langsung aja buat topologi yang akan kita gunakan pada lab ini
Konfigurasi R1
hostname R1
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
no shut
interface FastEthernet0/1
ip address 12.12.12.1 255.255.255.0
no shut
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
no shut
!
router bgp 1
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 12.12.12.2 remote-as 2
neighbor 13.13.13.3 remote-as 3
bgp bestpath as-path multipath-relax
do clear ip bgp * soft
no auto-summary
!
Konfigurasi R2
hostname R2
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
!
interface FastEthernet0/1
ip address 12.12.12.2 255.255.255.0
!
interface FastEthernet1/0t
ip address 23.23.23.2 255.255.255.0
!
router bgp 2
bgp log-neighbor-changes
neighbor 12.12.12.1 remote-as 1
neighbor 24.24.24.4 remote-as 4
no auto-summary
Konfigurasi R3
hostname R3
interface FastEthernet0/0
ip address 34.34.34.3 255.255.255.0
!
interface FastEthernet0/1
ip address 13.13.13.3 255.255.255.0
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
!
router bgp 3
bgp log-neighbor-changes
neighbor 13.13.13.1 remote-as 1
neighbor 34.34.34.4 remote-as 4
no auto-summary
!
Konfigurasi R4
hostname R4
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
!
interface FastEthernet0/1
ip address 34.34.34.4 255.255.255.0
!
router bgp 4
network 8.8.8.8 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 2
neighbor 34.34.34.3 remote-as 3
no auto-summary
Lakukan verifikasi
Sekarang sudah load sharing. Permasalahnnya adalah seandainya bandwidth kedua ISP tersebut berbeda maka bagaimana proses sharing antara kedua link tersebut?. Maka perlu tambahan konfigurasi berikut ini di R1.
R1(config)#interface fa0/1
R1(config-if)#bandwidth 100
R1(config-if)#ex
R1(config)#interface fa0/0
R1(config-if)#bandwidth 200
R1(config-if)#do clear ip bgp *
R1(config)#router bgp 1
R1(config-router)#bgp dmzlink-bw
R1(config-router)#neighbor 12.12.12.2 dmzlink-bw
R1(config-router)#neighbor 13.13.13.3 dmzlink-bw
R1(config-router)#do clear ip bgp *
Lalu verifikasi kembali, apakah sudah load sharing.
Success...!!!
Seperti yang terlihat sekarang sudah load sharing dalam perbandingan yang baik, sehingga kedua link tersebut bisa digunakan sesuai kemampuannya.
Posting Komentar untuk "Cisco | BGP - Multihoming - ISP Berbeda (Load Sharing)"