Lompat ke konten Lompat ke sidebar Lompat ke footer

BGP - Attribute (Community) + Aggregator

Kali ini, kita akan praktek di BGP "atribute community" dimana ada beberapa network yg sudah diadvertise sebelumnya tidak akan lagi di tampilkan di router tetangga dengan penambahan konfigurasi kusus yaitu no-export dan no-advertise.

1. No Export

Konfigurasi R1
R1#conf
R1(config)#int fa0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.255
R1(config-if)#no shu
R1(config-if)#exi

R1(config)#int lo1
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#exi
R1(config)#

R1(config)#int lo2
R1(config-if)#ip add 11.11.11.11 255.255.255.255
R1(config-if)#exi
R1(config)#

R1(config)#router eigrp 1
R1(config-router)#net 1.1.1.1 0.0.0.0
R1(config-router)#net 12.12.12.1 0.0.0.0
R1(config-router)#exi
R1(config)#

R1(config)#router bgp 123
R1(config-router)#neig 2.2.2.2 remot 123
R1(config-router)#neig 2.2.2.2 up lo1
R1(config-router)#network 11.11.11.11 mask 255.255.255.255

Konfigurasi R2
interface fa0/0
ip address 12.12.12.2 255.255.255.0
no sh
exi

interface fa0/1
ip address 23.23.23.2 255.255.255.0
no sh
exi

interface se0/0
ip address 24.24.24.2 255.255.255.0
no sh
exi

int lo1
ip add 2.2.2.2 255.255.255.255
exi

int lo2
ip add 22.22.22.22 255.255.255.255
exi

router eigrp 1
net 2.2.2.2 0.0.0.0
net 12.12.12.2 0.0.0.0
net 23.23.23.2 0.0.0.0
exi

router bgp 123
neig 24.24.24.4 remot 4
neig 1.1.1.1 remot 123
neig 1.1.1.1 up lo1
neig 1.1.1.1 next-hop-self

neig 3.3.3.3 remot 123
neig 3.3.3.3 up lo1
neig 3.3.3.3 next-hop-self
neig 3.3.3.3 route-reflector-client

net 22.22.22.22 mask 255.255.255.255
net 24.24.24.2 mask 255.255.255.255

Konfigurasi R3
interface fa0/1
ip address 23.23.23.3 255.255.255.0
no sh
exi

int lo1
ip add 3.3.3.3 255.255.255.255
exi

int lo2
ip add 33.33.33.33 255.255.255.255
exi

router eigrp 1
net 3.3.3.3 0.0.0.0
net 23.23.23.3 0.0.0.0
exi

router bgp 123
neig 2.2.2.2 remot 123
neig 2.2.2.2 up lo1
net 33.33.33.33 mask 255.255.255.255

Konfigurasi R4
interface se0/0
ip address 24.24.24.4 255.255.255.0
no sh
exi

int lo0
ip add 4.4.4.4 255.255.255.255
exi

router bgp 4
neigh 24.24.24.2 remot 123
netw 4.4.4.4 mask 255.255.255.255

VERIFIKASI:


Cek BGP route di R1 dan R4


Lalu set community "no-export" di R1 (no-export tidak di tampilkan di eBGP, artinya host 11.11.11.11/32 tidak akan di muncul ke R4 karena berbeda AS number.

R1(config)#access-list 1 permit host 11.11.11.11
R1(config)#route-map NO-EXPORT
R1(config-route-map)#match ip address 1
R1(config-route-map)#set community no-export
R1(config-route-map)#ex

R1(config)#router bgp 123
R1(config-router)#neighbor 2.2.2.2 route-map NO-EXPORT out
R1(config-router)#neighbor 2.2.2.2 send-community
R1(config-router)#

Cek BGP route di R4, pastikan network 11.11.11.11/32 tidak ada lagi di R4

Kita lanjut set community di R3 "no-advertise", artinya tidak akan meng-advertise network 33.33.33.33/32  ke iBGP/eBGP.

Sebelum verifikasi dan lanjut pastikan masih ada network R3 di R1, R2 dan di R4.


2. No - Advertise (artinya
tidak diadvertise ke peer manapun, baik iBGP maupun eBGP)
Lanjutkan konfigurasi ini di R3
R3(config)#access-list 1 permit host 33.33.33.33
R3(config)#route-map NO-ADVERTISE
R3(config-route-map)#match ip address 1
R3(config-route-map)#set community no-advertise
R3(config-route-map)#ex

R3(config)#router bgp 123
R3(config-router)#neighbor 2.2.2.2 route-map NO-ADVERTISE out
R3(config-router)#neighbor 2.2.2.2 send-community
R3(config-router)#

Verifikasi di R1,  jika konfigurasi benar, maka seharusnya network 33.33.33.33/32 tidak ada lagi di R1, R2 dan R4


3. BGP - Aggregator
Sekarang kita akan bahas Aggregator, tujuannya adalah meringkas IP. Jika di routing protocol lain seperti OSPF, EIGRP sering disebut istilah Summary. Untuk mempraktekkan aggregator,kita akan tambahkan IP interface Loopback di R4.
Langsung saja ke konfigurasinya

R4(config)#interface  lo1
R4(config-if)#ip address 40.1.1.1 255.255.255.255
R4(config-if)#ex

R4(config)#interface  lo2
R4(config-if)#ip address 40.2.1.1 255.255.255.255
R4(config-if)#ex

R4(config)#interface  lo3
R4(config-if)#ip address 40.6.1.1 255.255.255.255
R4(config-if)#ex

R4(config)#interface  lo4
R4(config-if)#ip address 40.3.1.1 255.255.255.255
R4(config-if)#ex

R4(config)#interface  lo4
R4(config-if)#ip address 40.5.1.1 255.255.255.255
R4(config-if)#ex

R4(config)#interface  lo6
R4(config-if)#ip address 40.6.1.1 255.255.255.255
R4(config-if)#ex

Lalu Advertise Netaworknya di BGP

R4(config)#router bgp 4
R4(config-router)#network 40.1.1.1 mask 255.255.255.255
R4(config-router)#network 40.2.1.1 mask 255.255.255.255
R4(config-router)#network 40.3.1.1 mask 255.255.255.255
R4(config-router)#network 40.4.1.1 mask 255.255.255.255
R4(config-router)#network 40.5.1.1 mask 255.255.255.255
R4(config-router)#network 40.6.1.1 mask 255.255.255.255

Lalu coba verifikasi di R1, apakah netowork yg di advertise di R4 muncul di routing table R1?
Lalu lakukan aggregate di R4

R4(config)#router bgp 4
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0

Cek kembali BGP route table nya di R1

Lalu lakukan konfigurasi aggregation dengan tambahan summary-only di R4

R4(config)#router bgp 4
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0 summary-only
Maka hasil ahir dari aggregation, lihat di R1, IP Loopback sudah diringkas.

Posting Komentar untuk "BGP - Attribute (Community) + Aggregator"